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1 INTRODUCTION 

This example goes through steps to perform spectral fatigue analysis based on static analysis for 
an offshore fixed platform using Sesam software suite. The model file used in this analysis is the 
model from Inplace analysis with pile foundation. 

2 MODEL MODIFICATION 

The model used to perform the Inplace analysis will be modified to include the deterministic wave 
load approach in Wajac, pile soil analysis in Sestra and Splice with the spectral fatigue approach in 
Framework. 

2.1 Importing Model from Inplace Analysis 

Open Sesam Manager, name it as Spectral_Fatigue_Static. Then drag GeniE into the work area, 
and name is as GeniE_SpecFatStatic. Change GeniE units to kN, m, and delC; 

 

To launch GeniE, just RMB on GeniE_ SpecFatStatic and click 
Run. A new GeniE workspace is now open.  

 

To import the model file Model_SpectralFatigue_Start.gnx into GeniE, go to File > Import > 
Workspace (GNX file). The structure will be displayed on the screen as below. 
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2.2 Revise the Model 

The model file Model_SpectralFatigue_Start.gnx is used for the inplace analysis. We need to 
revise it to make it suitable for the static spectral fatigue analysis. 

 

2.2.1 Revise Hydro Properties and Delete Waves/Currents 

The existing Morison coefficients were input for the inplace analysis. They need to be changed as 
below for a fatigue analysis. 
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Delete the existing waves, currents, and the condition under the Location.  

 
 

2.2.2 Delete Analysis and Capacity Models 

Delete the existing analysis WavePileSoilAnalysis and all capacity models (if any). 

 
 

2.3 Waves and Wave Condition 

Input determanistic wave. To create the waves, go to Environment > Water, RMB click, select 
New Regular Wave Set. Name the wave set as WaveSet_Det. 

 
Add at least 15 lines by using     key on the keyboard. Enter five waves for each direction (0 deg, 
52 deg, and 90 deg). 
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Create Condition_Det under Location1, set WaveSet_Det as the Regular wave set, and choose 
wave model as Airy.   
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3 STATIC ANALYSIS – GENIE 

A static analysis is created and performed in GeniE. The analysis includes the Wajac wave load 
calculations and the Splice/Sestra static analysis. 

3.1 Creating Analysis   

A static pile-soil analysis with wave load condition of Condition_Det is created. Uncheck the 
option Automatically import global loadcases to exclude all user defined load cases.   

 

 

3.2 Meshing Activity 

The following meshing options are selected.  
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3.3 Editing Wave Loads 

RMB click 1.2 – Wave Load Analysis, select Edit Wave Load Analysis. 

 
 Deterministic seastates tab 

When a wave is passing through the structure, the wave step size is selected as 20 degrees 
and the total number of steps is 19. The Buoyancy calculation and Doppler Effect are turned 
off. The design load criteria is NoDesignLoads. Wajac will calculate the wave load for each 
wave step. 

Click Fill all to implement the selected options, and Click Apply to save the inputs and keep 
the dialog open.  

 
Note: For a static analysis the number of wave steps can be 18 as well.  
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 Buoyancy tab 

The option Include weight of marine growth is unchecked. Click Apply to save the change and 
keep the dialog open.  

 
 Output tab 

The center point at the mudline is selected as the Moment reference point. Click Apply to 
save the input. 

 
 

Finally, click OK to close the dialog box. Total 285 wave load cases are created and displayed in 
the analysis folder. 
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3.4 Editing Splice Soil Analysis 

The default options are used in the Splice Soil Analysis. Splice soil analysis analyzes the structure 
for all wave load cases and generate beam forces and moments. 

3.5 Creating a Set for Fatigue Damage Calculation 

A set containing a joint and all beams connected to the joint is created and will be included in the 
Framework fatigue damage calculations. 

 Select JT176 and all connected beams, see right. Create a set and 
name it as Set_Fat. This set will be included in the fatigue analysis in 
Framework.  

 

3.6 Executing Analysis 

Perform the analysis by clicking Start on 
Activity Monitor dialog box.  

The analysis results are stored in the result 
file _R1.SIN.  

 

 

Save the model and export it to _repository folder as Model_SpectralFatigue_Done.gnx Export 
the results SIN file to _repository folder with the name of StaticSpectral_R1.SIN.  
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4 SPECTRAL FATIGUE ANALYSIS – FRAMEWORK 

With the results in place, the static spectral fatigue analysis can be run. 

First, create an empty text file in _repository folder named Framework_open.jnl. This will be 
used to start Framework without any commands and without opening the results file yet, so that 
some default settings can be specified first (which are applied to the result file upon opening it). 

Drag Framework into the work area, and name it as Framework_SpecFat. In the Framework 
activity properties browse to select the CmdInputFile and select the newly created 
Framework_open.jnl file in _repository as the input file. 

After specifying the command input file, right click Framework activity to run Framework.  

 
 

4.1 General Input 

Before import the result file, global fatigue parameters need to be defined in a new Framework 
workspace.   
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4.1.1 Fatigue Constants and Global Settings 

 Go to Define > Fatigue Constants to 
open the dialog for inputting the 
global fatigue check options.  

 

 

 Enter the selections as shown below. Click OK to confirm inputs.  

 

 Go to Define > Near Chord Rule and 
enable the checkbox Use Near Chord.  
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NOTE: This will ensure that the chord member and the aligned chord member of a brace do not 
change when the structure and its load pattern are subject to a rotation. This is useful when 
multiple fatigue analyses are performed on the same model in different states, e.g. when the 
model is standing and when the same model is placed horizontally for transportation in another 
fatigue analysis. This ensures that the hotspots are the same in both analyses, so that results can 
be summed correctly. 

 Go to Define > Fatigue Check Weld 
Root and enable the option. Then 
fatigue damages will be checked at 
weld root positions for tubular joint 
welds and butt-welds. 

 

Note: The commands DEFINE NEAR-CHOR-RULE and DEFINE FATIGUE-CHECK-WELD-ROOT must 
be issued before the result file is read in.  

4.1.2 Importing Result File 

Now the result file can be read into Framework. 

 Go to File > Open. Click the browse folder button and locate the StaticSpectral_R1.SIN file in 
_repository folder, press OK.   

Transfer Superelement dialog box is opened. Leave all defaults as is and press OK to start 
reading in the results file. 
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 After the file is read in, click Display 
> Member to get the structure 
displayed.  

 

4.1.3 Specifying Task and Analysis 

 Define the task by going to Task > Fatigue Check. This 
will limit the displayed menu items in Framework to 
those relevant for a fatigue analysis. 

 

 Go to Select > Fatigue Check Type > 
Spectral to define that a spectral fatigue 
analysis will be run. 
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4.1.4 Setting Up Print Output 

 Go to Set > Print to set Print Options 
as shown in the image, define the file 
name as 
Framework_SpecFat_Joints_Report 

 

4.2 Fatigue Loads – Wave Scatter Diagrams 

Next, the environmental data will be specified and assigned to each wave direction.  

 Go to Create > Wave Statistics, input the 
wave scatter diagram. This scatter 
diagram will be applied in all three wave 
directions. Input Hs, Tz, & Percentage (%), 
and select Include. Repeat to complete 
the entire scatter diagram, then click OK. 

 Alternatively, the data can be read in via a 
command file. Click the Read Command 
Input File button in the toolbar. Select the 
wave_scatter.jnl file from the input files.  

 

NOTE: Make sure that there are no spaces in the path to the input file, otherwise Framework will 
fail to read it in.   

 Assign the wave spectrum 
shape to each wave scatter 
diagram via Assign > Wave 
Spectrum Shape as Pierson-
Moskowitz spectrum. 
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 Assign the scatter diagram to 
each wave direction. Go to 
Assign > Wave Statistic, select 
0.0-degree wave direction and 
click SCAT wave statistic, press 
Apply. Repeat this for waves in 
52 and 90 degree directions. 

 Click Cancel to close the dialog 
box. 

 

 Assign the wave direction 
probabilities via Assign > Wave 
Direction Probability. Assign a 
probability of 0.36 to direction 
0 degree, a probability of 0.40 
to direction 52 degrees, and a 
probability of 0.24 to direction 
90 degrees. 

 Click Cancel to close the dialog 
box. 

 

4.3 Joint and Member Selection 

The joints and members included in the fatigue analysis can be selected before the analysis is 
performed. If the set name of joints and members are longer than 8 characters, Framework will 
rename them. The naming map is reported in Framework.MLG file.  

 

 Go to Select > Joint Set > Set, select the set S8, then 
click Only and Close.   
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 Go to Select > Member Set, select 
Connected to Joint option, click Only 
and Close. 

  

4.4 SCF Related Inputs 

In a fatigue analysis, user needs to define SCF calculation rules for tubular connections and for 
butt-welds. If needed local SCFs can be defined for some selection tubular connections and the 
selected butt-weld positions.  

The following commands are under Assign menu. We only define SCFs for joints in this section.  

 Go to Assign > Joint Type, click 
Joint Type and select Loadpath. 
This will be assigned to the 
selected joint set S9 and all 
braces connected to the joints. 
The defined joint classification 
rule will be used in SCF 
calculations.  

 

 Go to Assign > Joint Gap and 
make sure that gaps are 
automatically computed based 
on the modelled gaps for all 
selected joints. 

 

 Go to Assign > Joint Chord 
Length and make sure that the 
calculated chord length from 
the model is used as the chord 
length for SCF calculations. 
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 Go to Assign > SCF > Joint, assign 
parametric SCFs according to 
Efthymiou to all joints. 

 

4.5 S-N Curve Related Inputs 

In Framework, user can enter S-N curve related inputs using Assign commands. 

The global S-N curve is defined in Fatigue Constants. User is able to define different ones for 
some selected joints. User can also specify the S-N curve thickness correction to for the selected 
S-N curves.   

 Go to Assign > Thickness Correction, select the curve 
DNV2010_T and make sure a Standard T-curve is used 
for the thickness correction with the reference thickness 
set to 32 mm (i.e. 0.032 m). Press Apply and Close.  

 

4.6 Fatigue Analysis for Tubular Connections 

The spectral fatigue damage analysis for tubular connections will now be run. In this example the 
tubular connections and members included in set Set_Fat are included in the analysis.  
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 Go to Run > Fatigue 
Check, name the run as 
FT_JT, select members 
included in the set 
SET_FAT, press OK to run 
the analysis. 

 
 After the analysis completed, go to Print > Fatigue Check Results, select the analysis results to 

be printed into the listing file for tubular connections included in set SET_FAT.  

 
The fatigue listing file is located in Framework_SpecFat activity folder. The results are reported as 
below. 

 

NOTE: By default S-N curves DNV2010_E-AIR or DNV2010_F-AIR is assigned to the chord root 
position based on the brace thickness, and S-N curve DNV2010_F3-AIR is assigned to the brace 
root position.  
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There are some calculation data, such as tubular connection SCFs, the fatigue check data, and 
fatigue check positions, can also be printed. For example, the below command can be used to 
print out the details of S-N curves used in each connection and butt-weld position.  

PRINT MEMBER FATIGUE-CHECK-POSITIONS ( ) 

 

4.7 Fatigue Analysis for Member Butt-Welds 

The fatigue damage analysis can be performed for member butt-welds. In this analysis the butt-
welds on piles are checked.   

4.7.1 Pile Selection 

 Go to Select > Member Set, select Member and input Pile1 for Member (Pile) Name, click 
Only to include the selection.  

 Input the second pile Pile2 and click Include to add it to the selection.   

 Repeat the selection to include Pile3 and Pile4.  
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4.7.2 Pile Safety Factor 

 To include a different safety factor for pile fatigue checks, to Assign > Fatigue Safety Factor > 
Member, assign a fatigue safety factor of 10 to all piles.  

 

4.7.3 Set Up Print Output 

 Go to Set > Print, set Print Options as 
below, the listing file name is defined 
as Framework_SpecFat_Piles_Report. 

 

  

4.7.4 Executing Fatigue Analysis 

The fatigue analysis for butt-welds on piles can now be run. 

 Go to Run > Fatigue Check, name the run 
as FT_PL, press OK to run the analysis. 
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 After the analysis completed, 
go to Print > Fatigue Check 
Results, select the analysis 
results to be printed into the 
file. 

  

 

The fatigue analysis results for pile butt-welds are listed in the file located in Framework_SpecFat 
activity folder.  

 
NOTE: By default S-N curve DNV2010_F3-AIR is assigned to the butt-weld root position.  
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4.8 Framework Analysis Using Manually Created Framework.jnl file 

After the above analysis is finished, a journal file, Framework_SpecFat.JNL file is created in the 
Framework folder. Copy the file and paste it into _repository folder. Drag a new Framework 
activity into the work area, and name it as Framework_SpecFat_2. Choose the file 
Framework_SpecFat.JNL from _repository folder as CmdInputFile.  

 
RMB click Framework activity and run it. The same analysis is performed, and the same listing files 
will be generated in the analysis folder.  
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