
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

SESAM EXAMPLE  
Spectral Fatigue Analysis 

 
 

 

                                                           Using Equivalent Static Load Analysis 

  



 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Date: June 2025 
 
 
 
Prepared by DNV – Digital Solutions  
 
E-mail support: software.support@dnv.com 
 
E-mail sales: software@dnv.com 
 
 
 
 
 
 
 
 
 
 
 
© DNV AS. All rights reserved 
 
This publication or parts thereof may not be reproduced or transmitted in any form or by any means, 
including copying or recording, without the prior written consent of DNV AS. 
 

 



 

  
DNV – Sesam Example  Page   
 

Table of contents 

1 INTRODUCTION ............................................................................................................................................... 1 

2 MODEL MODIFICATION .................................................................................................................................. 1 
2.1 Importing Model from Eigenvalue Analysis 1 
2.2 Creating Transfer Function Waves 2 
2.3 Defining Wave Load Condition 3 
2.4 Creating a Set for Fatigue Damage Calculations 4 

3 DYNAMIC ANALYSIS – GENIE ........................................................................................................................ 4 
3.1 Creating Analysis 5 
3.2 Editing Meshing 5 
3.3 Editing Wave Load Analysis 6 
3.4 Generating Load Combinations 8 
3.5 Editing Linear Sestra Analysis 9 
3.6 Editing Splice Analysis 10 
3.7 Executing Analysis 10 
3.8 Structural Dynamic Responses 11 

4 SPECTRAL FATIGUE ANALYSIS – FRAMEWORK ....................................................................................... 12 
4.1 General Input 13 
4.1.1 Fatigue Constants and Global Settings 13 
4.1.2 Importing Result File 15 
4.1.3 Specifying Task and Analysis 16 
4.1.4 Setting Up Print Output 16 

4.2 Fatigue Loads – Wave Scatter Diagrams 16 
4.3 Joint and Member Selection 17 
4.4 SCF Related Inputs 18 
4.5 S-N Curve Related Inputs 19 
4.6 Fatigue Analysis for Tubular Connections 20 
4.7 Fatigue Analysis for Member Butt-Welds 21 
4.7.1 Pile Selection 21 
4.7.2 Pile Safety Factor 22 
4.7.3 Set Up Print Output 22 
4.7.4 Executing Fatigue Analysis 22 

4.8 Framework Analysis Using Manually Created Framework.jnl file 23 
 
 
 
 
 
 
 
  
 



 

DNV – Sesam Example  Page 1
 
 

 

1 INTRODUCTION 

This example goes through steps to perform spectral fatigue analysis for an offshore fixed 
platform using Sesam software suite. The model file uses in this analysis is the model with 
linearized pilehead springs and the pile foundation. 

2 MODEL MODIFICATION 

The model used to perform the Eigenvalue analysis will be modified to include a set of waves to 
perform a dynamic analysis for transfer function generations.  

2.1 Importing Model from Eigenvalue Analysis   

Open Sesam Manager, name it as Spectral_Fatigue. Then drag GeniE into the work area, and 
name is as GeniE_SpecFat. Change GeniE units to kN, m, and delC; 

 

To launch GeniE, just RMB on GeniE_ SpecFat and click Run. A 
new GeniE workspace is now open.  

 

To import the model file Model_SpectralFatigue_Start.gnx into GeniE, go to File > Import > 
Workspace (GNX file). The structure will be displayed on the screen as below. 
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Note that the model file Model_SpectralFatigue_Start.gnx is the same model file as 
Model_Eigenvalue_Analysis_Done.gnx.  

2.2 Creating Transfer Function Waves 

For the structure used in this example, the waves in three directions, 0 degree, 52 degrees, and 90 
degrees, are as below and will be input into the model.  

 
Note: Transfer function waves are selected by users based on the structural dynamic characters. 
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ISO 19902 2020 Section A.16.7.2.2 provides the guidelines for the selection of transfer function 
wave frequencies. 

 To create new waves, go to Environment > 
Water > Regular Waves. Right-click Regular 
Waves folder and select New Regular 
Wave Set.  

 

 In the dialog box, name this new wave set 
as WaveSet_Dynamic and add at least 96 
(total number of seastates) lines by using ↓ 
downward key on the keyboard.  

 
 Copy wave Period, Height, 

Phase angel, and Direction 
for all waves from the Excel 
spreadsheet and then paste 
them into this wave set.  

 

Once completed, click OK and the wave set will be created.  

2.3 Defining Wave Load Condition 

A new wave condition will be created to include the wave set WaveSet_Dynamic in order to 
include waves in the analysis.  
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 Create wave load condition under Location1, 
right-click on Location1 and select New Wave 
Load Condition. 

 

 Define the wave condition name as 
Condition_Dynamic, select wave 
set WaveSet_Dynamic, use Airy as 
wave model for all waves, and then 
include two additional seastates 
with CalmSea wave model.  

 

 Click OK and Condition_ Dynamic is now created. This wave load condition will be included in 
the dynamic analysis.  

2.4 Creating a Set for Fatigue Damage Calculations 

A set containing a joint and all beams connected to the joint is created and will be included in the 
Framework fatigue damage calculations. 

 Select JT176 and all connected beams, see right. Create a set and name it 
as Set_Fat. This set will be included in the fatigue analysis in Framework.  

 

3 DYNAMIC ANALYSIS – GENIE 

A new analysis containing a linear dynamic analysis and a non-linear Splice analysis is created. The 
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linear dynamic analysis is performed to generate the structural dynamic responses with 
equivalent static loads, and then the Splice analysis is executed to analyze the structure with the 
pile-soil foundation.  

Please note that there are two sets of support conditions included in the model. The pilehead 
springs will be included in the linear dynamic analysis and the pile-soil foundation will be used in 
the subsequent non-linear Splice analysis.  

3.1 Creating Analysis   

 To create the analysis, go to Analysis > Activities, right-click 
and select New Analysis. 

 
 

 Generate the analysis following the 
sequence: 1) Name the analysis to 
Analysis_Dynamic, 2) keep Linear 
Structural Analysis checked, and check 
Wave Load Activity, 3) include 
Condition_Dynamic for Wave Load 
Condition, 4) select Dynamic and check Use 
Equivalent Static Loads – Fatigue, 5) select 
Pile Soil Analysis.  

 Click OK to confirm selections.  

 

 

Now the new dynamic analysis is created. Exclude wind load cases, LCEqWind0, LCEqWind52, and 
LCEqWind90 from the analysis. 

3.2 Editing Meshing 

Use Alt+D to open the Activity Monitor, 
right-click on 1.1 – Meshing and select Edit 
Mesh Activity. 
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 Change Regenerate mesh option to Always 
Regenerate Mesh. Uncheck Smart Load 
Combination and check the option First level 
combinations as BSELL. This will make the 
load combination passed to add to the 
generated equivalent static loads (ESL).  

 Select Linear Springs At Pile Head as the Pile 
boundary condition to provide the support 
condition for the linear dynamic analysis. 
Enter the set PileHeadSprings as the Subset.  

Note that all piles contained in the model will 
be automatically included in the Splice 
analysis.  

 Click OK to save the selections.  

 

3.3 Editing Wave Load Analysis 

 Righ-click on 1.2 – Wave Load Analysis 
and select Edit Wave Load Analysis. 

 

 Edit the wave load activity in the newly created analysis. Set the wave step length to 12 
degrees, the number of steps to 31. Set buoyancy calculation Off and doppler effect Off, then 
click Fill all. Click Apply to save the input but keep the dialog box open.  

NOTE: In a dynamic analysis wave steps should include a full cycle 0 – 360 degrees wave 
propagation, such as if wave step length equal to 12 degrees, then 31 (instead 30) wave load 
steps should be used for wave load generation. Also, the number of wave steps must be less 
than 36. 
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 On the Added mass and damping tab, select 
Calculate added mass and choose options 
Include internal water, Use Cm=2.0, and Include 
longitudinal mass of marine growth and internal 
water. Click Apply.  

 

 On the Buoyancy tab, uncheck Include weight of 
marine growth option.  

NOTE: This option excludes the marine growth 
weight and buoyancy in the wave load 
calculations for seastates 1 to 99, which will be 
used in subsequent direct time domain dynamic 
analysis. Click Apply to save the inputs.  

 

 



 

DNV – Sesam Example  Page 8
 
 

 Go back to Deterministic Seastates tab. Set two Calmsea load cases with the first calmsea line 
to account for the buoyancy of structure and buoyancy of marine growth, the second calmsea 
load case to account for the weight of marine growth.  

 

 Click OK to apply all inputs and close the dialog box.  

3.4 Generating Load Combinations 

The mass of equipment and live load should be included in the dynamic analysis. Therefore, a load 
combination for these two load cases needs to be created and loads included in the load 
combination will be converted to mass in the dynamic analysis.  

 Go to Analysis > Activities > Analysis_Dynamic, select load cases, LCEq and LCLLoad, which 
are included in the load combination, right-click and select New Load Combination. 

 Name the load combination with name LComb_Mass_Dynamic. Check options Point and line 
loads and Placed equipment with Footprint-Mass. Give the load factor for each load cases as 
shown below. Loads included in this load combination will be converted to mass in the 
analysis and the weight of these masses will be included in the load case, LCGrav, in which the 
structural self-weight is included.  

  
Since a Splice analysis will be performed after the dynamic analysis, a load combination 
containing all vertical loads, such as the structural self-weight, equipment loads, deck live loads, 
marine growth weight, and all buoyancies, need to be created. The calculated dynamic effect plus 
the loads in this load combination will be included in the static Splice analysis.  

 To create a load combination for ESL 
analysis, select load case LCGrav, LCBuoy, 
Analysis_Dynamic.WLC(97,1) and 
Analysis_Dynamic.WLC(98,1), right-click 
and choose New Load Combination. 
Name it as LCOMB_VLoads.  

 The load case factors are shown in the 
image. 
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Now two load combinations are included in the analysis. 

 

3.5 Editing Linear Sestra Analysis  

The dynamic analysis parameters, such as the analysis method, Rayleigh damping ratios, the time 
integration step size, the option to store reaction forces, the options to include the combined vertical 
loads, and the options of storing ESL result interface file, need to be defined.  

 Right-click on 1.3 – Linear Structural 
Analysis and select Edit Linear Sestra 
Analysis.  
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 Enter the following parameters:  

i. Raileigh damping ratios Alpha1 
= 0.04986; Alphat2 = 0.005245; 

ii. Set the Time step to 0.02;  

iii. Check Use Cyclic Loads and 
Steady State Detection;  

iv. Enter Max Cycles to 100 and 
Store Cycles to 1; 

v. Check Store Reaction Forces; 

vi. Set the Reaction Forces Centre 
to point (0m, 0m, -124m);  

vii. Input ESL Factor to 1. Use FEM 
Loadcase number of 
LCOMB_VLoads and set it as 
ESL Load Comb.  

viii. Check Store ESL Result 
Interface File and Use text 
format for ESL file.  

Click OK to save all inputs.  

3.6 Editing Splice Analysis  

The Splice analysis will include the structural dynamic effects and the vertical loads. The results 
from this analysis will be used to perform a spectral fatigue analysis for the jacket structure and 
piles below the mudline.  

 All default options will be used in the Splice analysis.  

3.7  Executing Analysis  

With all the parameters set up, the analysis 
can now be run. 

 Click Alt+D on the keyboard to open the 
Activity Monitor and click Start to run the 
analysis.  

 The run will take some time to finish.  
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 To export the result file into _repository folder, go to 
File > Export > Result SIN File, and name the result file 
as Spectral_R1.SIN. 

 

Save the model and export it to _repository folder as Model_SpectralFatigue_Done.gnx.  

3.8 Structural Dynamic Responses 

Structural response files, reaction files for each wave (_reactions_history##.csv), and a transfer 
function file (_reactions_RAO.csv) are created automatically when the analysis is completed. All 
files are located at the analysis folder … Spectral_Fatigue\GeniE_SpecFat\Analysis_Dynamic. 

 
Below is the structural response for wave Period = 12.0 seconds, Height = 11.2376 m, Direction = 
0 degree taken from __reactions_history32.csv file. There are 20 cycles analysed, and the steady 
state is reached at the last cycle. Responses from the last cycle are saved and will be used in the 
Splice analysis.  

 
The __reactions_RAO.csv file can be opened to inspect the base shear and overturning moment 
transfer functions.  

 Create the base shear and overturning moment transfer functions using the data contained in 
__reactions_RAO.csv file.  

i. For base shears, compute the resultant base shears from the reported base forces in global 
X-direction and Y-direction.  

ii. For overturning moments, compute the resultant overturning moments from the reported 
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overturning moments about the global X-axis and the moments about the global Y-axis.  

 Generate base shear and overturning moment transfer function plots in Excel spreadsheet.   

 
 

4 SPECTRAL FATIGUE ANALYSIS – FRAMEWORK 

With the results in place, the spectral fatigue analysis can be run. 

First, create an empty text file in _repository folder named Framework_open.jnl. This will be 
used to start Framework without any commands and without opening the results file yet, so that 
some default settings can be specified first (which are applied to the result file upon opening it). 

Drag Framework into the work area, and name it as Framework_SpecFat. In the Framework 
activity properties browse to select the CmdInputFile and select the newly created 
Framework_open.jnl file in _repository as the input file. 

After specifying the command input file, click Framework activity to run Framework.  

Framework_open.jnl is also provided in the input file folder in this example.  
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4.1 General Input 

Before import the result file, global fatigue parameters need to be defined in a new Framework 
workspace.   

4.1.1 Fatigue Constants and Global Settings 

 Go to Define > Fatigue Constants to 
open the dialog for inputting the 
global fatigue check options.  

 

 

 Enter the selections as shown below. Click OK to confirm inputs.  
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 Go to Define > Near Chord Rule and 
enable the checkbox Use Near Chord.  

 

NOTE: This will ensure that the chord member and the aligned chord member of a brace do not 
change when the structure and its load pattern are subject to a rotation. This is useful when 
multiple fatigue analyses are performed on the same model in different states, e.g. when the 
model is standing and when the same model is placed horizontally for transportation in another 
fatigue analysis. This ensures that the hotspots are the same in both analyses, so that results can 
be summed correctly. 

 Go to Define > Fatigue Check Weld 
Root and enable the option. Then 
fatigue damages will be checked at 
weld root positions for tubular joint 
welds and butt-welds. 
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Note: The commands DEFINE NEAR-CHOR-RULE and DEFINE FATIGUE-CHECK-WELD-ROOT must 
be issued before the result file is read in.  

4.1.2 Importing Result File 

Now the result file can be read into Framework. 

 Go to File > Open. Click the browse folder button and locate the Spectral_R1.SIN file in 
_repository folder, press OK.   

Transfer Superelement dialog box is opened. Leave all defaults as is and press OK to start 
reading in the results file. 

 

 After the file is read in, click Display 
> Member to get the structure 
displayed.  
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4.1.3 Specifying Task and Analysis 

 Define the task by going to Task > Fatigue Check. This 
will limit the displayed menu items in Framework to 
those relevant for a fatigue analysis. 

 

 Go to Select > Fatigue Check Type > 
Spectral to define that a spectral fatigue 
analysis will be run. 

 

4.1.4 Setting Up Print Output 

 Go to Set > Print to set Print Options 
as shown in the image, define the file 
name as 
Framework_SpecFat_Joints_Report 

 

4.2 Fatigue Loads – Wave Scatter Diagrams 

Next, the environmental data will be specified and assigned to each wave direction.  

 Go to Create > Wave Statistics, input the 
wave scatter diagram. This scatter 
diagram will be applied in all three wave 
directions. Input Hs, Tz, & Percentage (%), 
and select Include. Repeat to complete 
the entire scatter diagram, then click OK. 

 Alternatively, the data can be read in via a 
command file. Click the Read Command 
Input File button in the toolbar. Select the 
wave_scatter.jnl file from the input files.  
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NOTE: Make sure that there are no spaces in the path to the input file, otherwise Framework will 
fail to read it in.   

 Assign the wave spectrum 
shape to each wave scatter 
diagram via Assign > Wave 
Spectrum Shape as Pierson-
Moskowitz spectrum. 

 

 Assign the scatter diagram to 
each wave direction. Go to 
Assign > Wave Statistic, select 
0.0-degree wave direction and 
click SCAT wave statistic, press 
Apply. Repeat this for waves in 
52 and 90 degree directions. 

 Click Cancel to close the dialog 
box. 

 

 Assign the wave direction 
probabilities via Assign > Wave 
Direction Probability. Assign a 
probability of 0.36 to direction 
0 degree, a probability of 0.40 
to direction 52 degrees, and a 
probability of 0.24 to direction 
90 degrees. 

 Click Cancel to close the dialog 
box. 

 

4.3 Joint and Member Selection 

The joints and members included in the fatigue analysis can be selected before the analysis is 
performed. If the set name of joints and members are longer than 8 characters, Framework will 
rename them. The naming map is reported in Framework.MLG file.  
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 Go to Select > Joint Set > Set, select the set S9, then 
click Only and Close.   

 

 Go to Select > Member Set, select 
Connected to Joint option, click Only 
and Close. 

  

4.4 SCF Related Inputs 

In a fatigue analysis, user needs to define SCF calculation rules for tubular connections and for 
butt-welds. If needed local SCFs can be defined for some selection tubular connections and the 
selected butt-weld positions.  

The following commands are under Assign menu. We only define SCFs for joints in this section.  

 Go to Assign > Joint Type, click 
Joint Type and select Loadpath. 
This will be assigned to the 
selected joint set S9 and all 
braces connected to the joints. 
The defined joint classification 
rule will be used in SCF 
calculations.  
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 Go to Assign > Joint Gap and 
make sure that gaps are 
automatically computed based 
on the modelled gaps for all 
selected joints. 

 

 Go to Assign > Joint Chord 
Length and make sure that the 
calculated chord length from 
the model is used as the chord 
length for SCF calculations. 

 

 Go to Assign > SCF > Joint, assign 
parametric SCFs according to 
Efthymiou to all joints. 

 

4.5 S-N Curve Related Inputs 

In Framework, user can enter S-N curve related inputs using Assign commands. 

The global S-N curve is defined in Fatigue Constants. User is able to define different ones for 
some selected joints. User can also specify the S-N curve thickness correction to for the selected 
S-N curves.   

 Go to Assign > Thickness Correction, select the curve 
DNV2010_T and make sure a Standard T-curve is used 
for the thickness correction with the reference thickness 
set to 32 mm (i.e. 0.032 m). Press Apply and Close.  
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4.6 Fatigue Analysis for Tubular Connections 

The spectral fatigue damage analysis for tubular connections will now be run. In this example the 
tubular connections and members included in set Set_Fat are included in the analysis.  

 Go to Run > Fatigue 
Check, name the run as 
FT_JT, select members 
included in the set 
SET_FAT, press OK to run 
the analysis. 

 
 After the analysis completed, go to Print > Fatigue Check Results, select the analysis results to 

be printed into the listing file for tubular connections included in set SET_FAT.  

 
The fatigue listing file is in Framework_SpecFat activity folder. The results are reported as below.
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NOTE: By default S-N curves DNV2010_E-AIR or DNV2010_F-AIR is assigned to the chord root 
position based on the brace thickness, and S-N curve DNV2010_F3-AIR is assigned to the brace 
root position.  

There are some calculation data, such as tubular connection SCFs, the fatigue check data, and 
fatigue check positions, can also be printed. For example, the below command can be used to 
print out the details of S-N curves used in each connection and butt-weld position.  

PRINT MEMBER FATIGUE-CHECK-POSITIONS ( ) 

 

4.7 Fatigue Analysis for Member Butt-Welds 

The fatigue damage analysis can be performed for member butt-welds. In this analysis the butt-
welds on piles are checked.   

4.7.1 Pile Selection 

 Go to Select > Member Set, select Member and input Pile1 for Member (Pile) Name, click 
Only to include the selection.  

 Input the second pile Pile2 and click Include to add it to the selection.   

 Repeat the selection to include Pile3 and Pile4.  
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4.7.2 Pile Safety Factor 

 To include a different safety factor for pile fatigue checks, to Assign > Fatigue Safety Factor > 
Member, assign a fatigue safety factor of 10 to all piles.  

 

4.7.3 Set Up Print Output 

 Go to Set > Print, set Print Options as 
below, the listing file name is defined 
as Framework_SpectFat_Piles_Report. 

 

  

4.7.4 Executing Fatigue Analysis 

The fatigue analysis for butt-welds on piles can now be run. 

 Go to Run > Fatigue Check, name the run 
as FT_PL, press OK to run the analysis. 

 



 

DNV – Sesam Example  Page 23
 
 

 After the analysis completed, 
go to Print > Fatigue Check 
Results, select the analysis 
results to be printed into the 
file. 

  

 

The fatigue analysis results for pile butt-welds are listed in the file located in Framework_SpecFat 
activity folder.  

 
NOTE: By default S-N curve DNV2010_F3-AIR is assigned to the butt-weld root position.  

4.8 Framework Analysis Using Manually Created Framework.jnl file 

After the above analysis is finished, a journal file, Framework_SpecFat.JNL file is created in the 
Framework folder. Copy the file and paste it into _repository folder. Drag a new Framework 
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activity into the work area, and name it as Framework_SpecFat_2. Choose the file 
Framework_SpecFat.JNL from _repository folder as CmdInputFile.  

 
RMB click Framework activity and run it. The same analysis is performed, and the same listing files 
will be generated in the analysis folder.  
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