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1 ABOUT THE WORKSHOP 

 

This workshop will guide you through how to create a section model .pln file from a 
floating offshore wind turbine (FOWT) foundation model in GeniE. The following 
steps will be explained: 

• Create curves from existing surfaces in GeniE 

• Prepare curves and export .pln file 

• Optional: Import the section model .pln file into HydroD 

 

The following files will be needed: 

• FOWT_Model.js 

• Optional: FOWT_PLN_Export.js 

(Note: Contains all command lines of all steps described in this workshop) 
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2 CREATE CURVES 

A .pln file consists of several patches, where each patch contains a set of curves, and 
each curve contains a set of point coordinates. These point coordinates are retrieved 
from the Guide Curves which will be created in this chapter.  
 
The number of curves will influence the quality of the .pln file. Patches are assumed to 
be linear between each point, thus curved edges and surfaces require a sufficient 
discretization. 
 

2.1 GeniE workspace 

The first step is to create a new GeniE workspace and prepare the FOWT foundation 
model. 

• Open GeniE V8.11 and create a new GeniE workspace. Make sure to set the user 

interface mode as full mode. 

• Select File > Read Command File and browse the FOWT_Model.js file to create 
the FOWT foundation model. 
 

    
 

2.2 Create curves for upper column 

(This sub-section explains the line 1~81 in the optional file FOWT_PLN_Export.js) 

2.2.1 Change default names for guide curves 

Before creating the curves, it is better to change the default names of new Guide 
Curves. This is for easy categorization of existing curves. 

• Select Edit > Rules > Default Names 
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• In Customize dialog: 

o Change Prefix of Guide Curve to “UpperColumn_RevolveSection” 
o Change Counter of Guide Curve to “1” 

 
• Click OK 

 

2.2.2 Create curves 

Create the curves of the upper column of set Column_1. 

• Select Pl7and Pl8 (i.e. the highlighted shells/plates in picture below) or select 
them in the Browser folder. 
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• Select Guiding Geometry > Curves on Surfaces > Plate/Shell Intersections with 

Family of Planes. 

 
• In the opened dialog, set the parameters as given below: 

o Select Y Plane  
o YCoord = 0 m 

o Radial Planes’ step: 180/39 
o Number of planes: 39 
o Around Axis Point: Point(-28.87 m,0 m,12 m) 
o Around Axis Direction: 0 0 1 
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• Toggle the Preview option to show the preview 

• Click OK 

• Go to browser folder Utilities – Guiding Geometry – Curves, observe that 40 new 
guide curves (Guide NURBS) named as UpperColumn_RevolveSection1~40 are 
generated. 
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2.3 Create curves for lower column 

2.3.1 Create curves for top circle of lower column 

(Line 83~163 in FOWT_PLN_Export.js) 

• Change default names of guide curve to set appropriate prefix and counter 
o Change Prefix of Guide Curve to “TopCircle_RevolveSection” 
o Change Counter of Guide Curve to “1” 

 
• Select Pl14 and Pl16. 

• Create curves using the Plate/Shell Intersections with Family of Planes again. 
(Note: No need to change settings in the dialog, since previous settings are 
remembered.) 

   
• In browser folder Utilities – Guiding Geometry – Curves, observe that 40 new 

guide curves named as TopCircle_RevolveSection1~40 are generated. 
 

2.3.2 Create curves for side plates of lower column 

(Line 165~245 in FOWT_PLN_Export.js) 

• Change default names of guide curve to set appropriate prefix and counter 
o Change Prefix of Guide Curve to “LowerColumn_RevolveSection” 
o Change Counter of Guide Curve to “1” 

 
• Select Pl1 and Pl2.  

• Create curves using Plate/Shell Intersections with Family of Planes 
(Note: No need to change settings in plate/shell intersections with family of 
planes dialog, since previous settings are remembered.) 
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• In browser folder Utilities – Guiding Geometry – Curves, observe that 40 new 

guide curves named as LowerColumn_RevolveSection1~40 are generated. 
 

2.4 Create curves for bottom plate 

Guide curves for bottom plate will be divided into outer part and inner part of the 
circle. 

2.4.1 Create curves for circle outer part of bottom plate 

(Line 247~355 in FOWT_PLN_Export.js) 

• Change default names of guide curves to set appropriate prefix and counter 
o Change Prefix of Guide Curve to “Bottom_CircleOuterSection” 
o Change Counter of Guide Curve to “1” 

 
 

• Select Pl5. 

• Create curves using Plate/Shell Intersections with Family of Planes and change 
parameters as given below.  

o Radial planes’ step: 180/40 
o Number of planes: 21 

• Click OK.  
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• In browser folder Utilities – Guiding Geometry – Curves, observe that 21 new 

guide curves named as Bottom_CircleOuterSection1~21 are generated. 

• Create two guide lines using the intersections points between Curve9 and 
Bottom_CircleOuterSection1, 11, and 21, respectively. 

o Click on  Guiding Geometry > Lines > From Two Points to create a new 
guide line. 

 
o Create guide line “Bottom_CircleOuterSection22” from Point(-19.87 m,0 

m,-20 m) to Point(-22.50603897 m,6.363961031 m,-20 m) 
(i.e. intersection points of Curve9 with Bottom_CircleOuterSection1 and 
11 marked with 1 and 2 in the image below. Only show these curves for 
easier point snapping.) 

o Create another guide line “Bottom_CircleOuterSection23” from Point(-
22.50603897 m,6.363961031 m,-20 m) to Point(-28.87 m,9 m,-20 m) 

(i.e. intersection points of Curve9 with Bottom_CircleOuterSection11 and 
21 marked with 2 and 3 in the image below) 
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• Select Bottom_CircleOuterSection1~11 and right-click one of them. Then select 

Divide. 

• Use Divide curves with structure method, divide against 
Bottom_CircleOuterSection22. 

  
 

• Select Bottom_CircleOuterSection12~21 and right-click > Divide. 

• Use Divide curves with structure method, divide against 
Buttom_CircleOuterSection23. 
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• Select curves Bottom_CircleOuterSection1~21 and right-click > Delete to keep 

only the shorter curves after the divide operation. 

  
• Also delete curve Bottom_CircleOuterSection23, since it will not be part of the 

patches to export. Deleting it can avoid possible mistake in creating sets of 
patches. 
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• Select curves Bottom_CircleOuterSection24~43 in Browses, right-click > Copy;  

• Select Mirror tab, set parameters as given below: 

o Point in mirror plane (P1): -28.87 0 -20 
o Mirror plane normal vector: 1 0 0 
o Toggle Preview 

• Click Apply. 

 

    
• Bottom_CircleOuterSection24~64 now form the outer circle patch. 

 

2.4.2 Create curves for circle inner part of bottom plate 

(Line 357~393 in FOWT_PLN_Export.js) 

• Change default names of guide curves to set appropriate prefix and counter 

o Change Prefix of Guide Curve to “Bottom_CircleInnerSection” 
o Change Counter of Guide Curve to “0” 

 
• Create a guide line “Bottom_CircleInnerSection0” from Point(-19.87 m,0 m,-20 

m) to Point(-28.87 m,0 m,-20 m) 
(i.e. End point of Bottom_CircleOuterSection24 and the center of the bottom 
plate) 
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• Rename Bottom_CircleOuterSection22 to “Bottom_CircleInnerSection1”, since 

this curve will belong to the inner circle patch 

       
• Create guide points along Bottom_CircleInnerSection0 

o Click on Guiding Geometry > Points > Curve Points at Equal Intervals 

 
 

o Click on the curve Bottom_CircleInnerSection0  
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o In Number of Points dialog, change value of Number to “11” and click OK. 

 
o Press Esc key to exit current creation function. 
o Observe that Point4~14 are created along the curve 

Bottom_CircleInnerSection0 at equal intervals. 

 
• To make snap to points in the following steps easier, change the selection 

switches of different item types: 
o Beam selection: OFF 

o Plate selection: ON 
o GuidePoint selection: ON 

 
• Create ten guide lines as shown in red below. Each guide line is created from 

Point4~14 to the end of curve Bottom_CircleOuterSection35~44, respectively. 

 
• Delete curve Bottom_CircleInnerSection0 since it will not be part of the patches 

to export. Deleting it can avoid possible mistake in creating sets of patches 
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• Copy mirror curves Bottom_CircleInnerSection1~10 

(Note: No need to change settings in copy dialog, since previous settings are 
remembered.) 

   
• Bottom_CircleInnerSection1~21 now forms the inner circle patch. 

 

3 COPY CURVES AND CREATE SETS 

3.1 Copy curves 

(Line 395~760 in FOWT_PLN_Export.js) 

• Before copying the curves, it’s better to set copy clone name rule. This way, 

curves created by copying will still be named after their original curves. 
o Open Edit > Rules > Default Names 
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o In Customize dialog, turn ON the Use copy clone name rule, and click OK 

 
• Select all curves created in Chapter 2, i.e., all curves named with the following 

prefixes: 
o UpperColumn_RevolveSection 

o TopCircle_RevolveSection 
o LowerColumn_RevolveSection 
o Bottom_CircleOuterSection 
o Bottom_CircleInnerSection 

• Copy translate all selected curves with Vector3d(43.305 m,25.00215341 m,0 
m) or by picking Guiding points: point 1 and point 3  
(i.e. Vector from center of Column_1 to Column_2) 
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• Select all the copied curves in above step, i.e., all curves named with suffix “_1”, 

then  
copy mirror with parameters given below 

o Point in mirror plane: Point(14.435 m,25.00215341 m,-20 m)  
(i.e. Point3) 

o Mirror plane normal vector: 0 1 0 

 
o Curves created by this step will be named with suffix “_1_1” 

 

3.2 Create sets 

(Line 762~777 in FOWT_PLN_Export.js) 
In the .pln file, each patch is equivalent to a Set in GeniE. It is therefore important that 
the curves are stored in the correct Sets before they are read into HydroD. 
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A total of 15 dynamic sets should be created. The name and content of each set is 
given in table below: 
Curves Set 

UpperColumn_RevolveSection1~40 UpperColumn_RevolvePatch 

UpperColumn_RevolveSection1_1~40_1 UpperColumn_RevolvePatch_1 

UpperColumn_RevolveSection1_1_1~40_1_1 Mirror_UpperColumn_RevolvePatch 

TopCircle_RevolveSection1~40 TopCircle_RevolvePatch 

TopCircle_RevolveSection1_1~40_1 TopCircle_RevolvePatch_1 

TopCircle_RevolveSection1_1_1~40_1_1 Mirror_TopCircle_RevolvePatch 

LowerColumn_RevolveSection1~40 LowerColumn_RevolvePatch 

LowerColumn_RevolveSection1_1~40_1 LowerColumn_RevolvePatch_1 

LowerColumn_RevolveSection1_1_1~40_1_1 Mirror_LowerColumn_RevolvePatch 

Bottom_CircleOuterSection24~64 Bottom_CircleOuterPatch 

Bottom_CircleOuterSection24_1~64_1 Bottom_CircleOuterPatch_1 

Bottom_CircleOuterSection24_1_1~64_1_1 Mirror_Bottom_CircleOuterPatch 

Bottom_CircleInnerSection1~21 Bottom_CircleInnerPatch 

Bottom_CircleInnerSection1_1~21_1 Bottom_CircleInnerPatch_1 

Bottom_CircleInnerSection1_1_1~21_1_1 Mirror_Bottom_CircleInnerPatch 

 
Taking UpperColumn_RevolvePatch as an example, follow these steps to create the 

dynamic set: 

• Go to browser folder, right-click Sets – Dynamic Sets and select New Dynamic Set. 

• Give the name as UpperColumn_RevolvePatch 

• Select And and Lhs 

• Select String and set Query as Name 

• Fill String Mask with UpperColumn_RevolveSection* 
 

 
 

• Select Rhs and Not, fill String Mask with UpperColumn_RevolveSection*_1 
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• Toggle the Preview option to show the preview 

 
• Click OK 
 
Repeat the steps above to create remaining dynamic sets as described in the following 
table. Note: Dynamic Set UpperColumn_RevolvePatch (marked red in the table) is 
already created by executing the steps above. 

 

Dynamic Set Name 

Conditions: 

And 

Lhs > String Rhs > Not > String 

UpperColumn_RevolvePatch UpperColumn_RevolveSection* UpperColumn_RevolveSection*_1 

UpperColumn_RevolvePatch_1 UpperColumn_RevolveSection*_1 UpperColumn_RevolveSection*_1_1 

TopCircle_RevolvePatch TopCircle_RevolveSection* TopCircle_RevolveSection*_1 

TopCircle_RevolvePatch_1 TopCircle_RevolveSection*_1 TopCircle_RevolveSection*_1_1 

LowerColumn_RevolvePatch LowerColumn_RevolveSection* LowerColumn_RevolveSection*_1 

LowerColumn_RevolvePatch_1 LowerColumn_RevolveSection*_1 LowerColumn_RevolveSection*_1_1 

Bottom_CircleOuterPatch Bottom_CircleOuterSection* Bottom_CircleOuterSection*_1 

Bottom_CircleOuterPatch_1 Bottom_CircleOuterSection*_1 Bottom_CircleOuterSection*_1_1 

Bottom_CircleInnerPatch Bottom_CircleInnerSection* Bottom_CircleInnerSection*_1 

Bottom_CircleInnerPatch_1 Bottom_CircleInnerSection*_1 Bottom_CircleInnerSection*_1_1 

The dynamic sets start with “Mirror” can be created by following steps: 
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• Create a new dynamic set and fill name as Mirror_UpperColumn_RevolvePatch 

• Select String and set Query as Name 

• Fill String Mask as UpperColumn_RevolveSection*_1_1 

• Click OK 

 
 
Repeat the steps above to create remaining dynamic sets as shown in the following 
table. 
Note: Dynamic Set Mirror_UpperColumn_RevolvePatch (marked red in the table) is 
already created by executing the steps above. 
 

Dynamic Set Name Conditions: String 

Mirror_UpperColumn_RevolvePatch UpperColumn_RevolveSection*_1_1 

Mirror_TopCircle_RevolvePatch TopCircle_RevolveSection*_1_1 

Mirror_LowerColumn_RevolvePatch LowerColumn_RevolveSection*_1_1 

Mirror_Bottom_CircleOuterPatch Bottom_CircleOuterSection*_1_1 

Mirror_Bottom_CircleInnerPatch Bottom_CircleInnerSection*_1_1 

 
Verify all dynamic sets have been created correctly. 

 
 
 
Note: Another way to create sets is by using Regular Set, first select the curves by their 
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name in the browser. For example, UpperColumn_RevolveSection1, 2, and so on. Then, 
press Alt+S to show only the selected curves to verify the selection. Finally, right-click 
one of them to add them to named sets. 

 
 

4 EXPORT PLN FILE 

(Line 779~782 in FOWT_PLN_Export.js) 
After all curves have been placed in sets, we can export the .pln file. 

• Click on menu File > Export > Polyline Approximations to PLN file 

 
• Set values in the “Set – IWET – Join” table as given below: 
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(Note: Use Tab key or Down arrow key to insert new rows in the table) 

Patch Set IWET Join 

1 Bottom_CircleOuterPatch_1 1 FALSE 

2 Bottom_CircleInnerPatch_1 1 FALSE 

3 LowerColumn_RevolvePatch_1 1 FALSE 

4 TopCircle_RevolvePatch_1 -1 FALSE 

5 UpperColumn_RevolvePatch_1 1 FALSE 

6 Mirror_Bottom_CircleOuterPatch -1 FALSE 

7 Mirror_Bottom_CircleInnerPatch -1 FALSE 

8 Mirror_LowerColumn_RevolvePatch -1 FALSE 

9 Mirror_TopCircle_RevolvePatch 1 FALSE 

10 Mirror_UpperColumn_RevolvePatch -1 FALSE 

11 Bottom_CircleOuterPatch 1 FALSE 

12 Bottom_CircleInnerPatch 1 FALSE 

13 LowerColumn_RevolvePatch 1 FALSE 

14 TopCircle_RevolvePatch -1 FALSE 

15 UpperColumn_RevolvePatch 1 FALSE 

• Specify other parameters in the dialog as given below 

o ISYM: 1 
o AP: -40.87 
o FP: 26.435 
o Approximation tolerance: 0.001 

• Set File name, for example, to “OWT_1.pln” 

• Click OK 

 
Note that the IWET starboard (left) and port (right) sides are local for each 
pontoon/column, not the global left or right side. The description of the IWET values 
corresponding to patch types in HydroD is shown below: 
 

IWET Description 

-10 WetLeftNoWaterline  

-1 WetLeft 

1 WetRight 

10 WetRightNoWaterline 
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• OWT_1.pln file will be exported and saved in the current GeniE workspace folder. 
 
Note: Completed model is also provided as FOWT_PLN_Complete.gnx and 
FOWT_PLN_Complete.xml files for reference. 
 

5 OPTIONAL: IMPORTING PLN FILE INTO HYDROD 

This last step illustrates how to import the .pln file into HydroD. 

• Start HydroD V7.2 and create a new workspace by selecting File > New. 
 

5.1 Create section model 

• Right-click the Models folder 

and select Add SectionModel. 
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• In the Properties view of the 
newly created SectionModel1, 
select OWT_1.pln as file name. 
(click the three dots button to 
browse the file) 

 
 

• Right-click SectionModel1 > 
Create patches from file. The 
section model should be visible 
in the 3D view. 
 

 

 

 
 

5.2 Create element model 

• Right-click the Models folder and 

select Add ElementModel. 

• In the Properties view of the 
newly created ElementModel1, 
tick Create from section model 
and select SectionModel1. 
 

 
 

• Right-click ElementModel1 > 
Generate mesh from section 
model.  
 

 
 

5.3 Verify and correct element model 

• Check the generated mesh by activating/deactivating the eye icons in the 
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workspace browser so that only the ElementModel1 is shown. 

• If the mesh edge is not shown, in ElementModel1 Properties view click Style tab 
and check Plates > Show edges. 

• Notice the mesh of the TopCircle patches is not good as shown below. The reason 

is that the last curve in the patch is reversed. 
 

 
 

• Expand SectionModel1 folder, expand PatchesFolder1, expand 
TopCircle_RevolvePatch_1, and select TopCircle_RevolvePatch_1_Polyline_39. 

 

• Reverse the points by copying the first row to the third row and then deleting the 
first row. The table should be as shown below after the operation: 

 

• Repeat the operation for Mirror_TopCircle_RevolvePatch_Polyline_39 and 
TopCircle_RevolvePatch_Polyline_39. 
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• Right-click ElementModel1 > Generate mesh from section model again. The mesh 
should be corrected now. 

 

 
 
Note: For more details on the settings of section model’s mesh generation, refer to 
HydroD example 4 “Wadam and Wasim analysis of a ship”
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